Version final-1

oficina: Oficina de instalação do provedor LEAP

Sempre quis hospedar sua própria VPN/email criptografado?

Bitmask

Essa sessão ajudará você respondendo qualquer dúvida durante a instalação do provedor LEAP numa máquina local vagrant ou em servidores remotos.

O projeto LEAP será apresentado brevemente, porém o foco principal é a sessão mão na massa, aonde vamos instalar um provedor LEAP funcional.

Nós seguiremos os passos básicos do tutorial linkado abaixo.

(EN)
Ever wanted to host VPN/encrypted email yourself ?

This session will help you with any questions how to install a LEAP provider either on a local vagrant node or one or more remote servers.

The LEAP project will be present shortly, the main focus is a hands-on session where we actually install a functional LEAP provider.

We'll follow the basic steps of the tutorial linked below.

Se você quer configurar seu próprio provedor num servidor remoto ou mesmo numa máquina virtual vagrant no seu laptop, por favor tenha certeza que você tenha os requisitos necessários. Isto é, resumidamente, tanto uma instalação vagrant funcionando no seu laptop ou um servidor remoto com o Debian estável (jessie - 8) instalado e acesso root ssh nele.

Para testar o Bitmask (a aplicação cliente necessária para acessar sua instalação do provedor de email criptografado/VPN) você necessita de um laptop rodando Linux (de preferência Debian ou Ubuntu), porque neste momento ele está apenas disponível para sistemas operacionais Linux. Mac OS/Windows serão em breve suportados.

(EN)
If you want to setup your own provider on a remote server or even in a vagrant box on your laptop, please make sure you have the requirements. This is, in a nutshell, either a working Vagrant installation on your laptop, or a remote server with a fresh Debian stable installation and ssh root access to it.

For testing Bitmask (the client application that's needed to access the newly setup VPN/encrypted email provider) you will need a Laptop running Linux (Debian or Ubuntu preferred), because at this time it's only available for the Linux operating systems.
Mac OS/Windows wil come hopefully soon.